There have been two industry-wide, hardware-based security flaws discovered recently by experts at Google Project Zero and other leading security firms. These vulnerabilities, nicknamed Meltdown and Spectre, exploit critical vulnerabilities in modern processors and allow programs to steal data which is processed on the computer. This might include passwords stored in a password manager or browser, personal photos, emails, instant messages and even business-critical documents.

Keeping user information secure is always Uniguest’s #1 priority and we have been taking active steps to address these security flaws. As of January 3, 2018, all of Uniguest’s infrastructure has been updated with the latest patches from Microsoft and Amazon to address the vulnerabilities, and we will be paying close attention to new patches and security updates as they are developed and made available to the public.

To date, Uniguest is unaware of any exploits of these security flaws or any evidence of malicious efforts. Furthermore, the existing protections on your Uniguest managed devices, including their physical security and session-based ephemerality, make the chances of any future exploit with respect to the Meltdown or Spectre security flaws existing on a Uniguest device extremely unlikely.

For more information on the “Meltdown” and “Spectre” CPU vulnerabilities, use the links provided below:

%d bloggers like this: